{"action":"Upgrade vm2 to 3.9.10 or later.","affected":[{"fixed":"3.9.10","introduced":"0"}],"component":"vm2","cve_ids":["CVE-2022-25893"],"ecosystem":"npm","epss":0.01542,"exploited":false,"fixed_versions":["3.9.10"],"ghsa_id":"GHSA-4w2j-2rg4-5mjw","id":"tcs_01M5KF1MCRKC860P2YDDAPQNKR","modified_at":"2023-11-08T04:08:51.082168Z","published_at":"2022-12-21T06:30:29Z","references":["https://osv.dev/vulnerability/GHSA-4w2j-2rg4-5mjw","https://nvd.nist.gov/vuln/detail/CVE-2022-25893","https://github.com/patriksimek/vm2/issues/444","https://github.com/patriksimek/vm2/pull/445","https://github.com/patriksimek/vm2/pull/445/commits/3a9876482be487b78a90ac459675da7f83f46d69","https://github.com/patriksimek/vm2","https://security.snyk.io/vuln/SNYK-JS-VM2-2990237"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-4w2j-2rg4-5mjw","url":"https://osv.dev/vulnerability/GHSA-4w2j-2rg4-5mjw"}],"summary":"vm2 vulnerable to Arbitrary Code Execution"}