{"action":"Upgrade apache-airflow to 2.4.0rc1 or later.","affected":[{"fixed":"2.4.0rc1","introduced":"2.3.0"}],"component":"apache-airflow","cve_ids":["CVE-2022-40604"],"ecosystem":"PyPI","epss":0.02083,"exploited":false,"fixed_versions":["2.4.0rc1"],"ghsa_id":"GHSA-5rp4-749p-vx26","id":"tcs_01M5KF1P7V4RARHW0SENVBYMNM","modified_at":"2024-09-11T18:46:30.185320Z","published_at":"2022-09-22T22:40:27Z","references":["https://osv.dev/vulnerability/GHSA-5rp4-749p-vx26","https://nvd.nist.gov/vuln/detail/CVE-2022-40604","https://github.com/apache/airflow/pull/26337","https://github.com/apache/airflow/commit/18386026c28939fa6d91d198c5489c295a05dcd2","https://github.com/apache/airflow/commit/6f24836e5ee56c452947aa87f84a21dd4f8eb87c","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-279.yaml","https://lists.apache.org/thread/z20x8m16fnhxdkoollv53w1ybsts687t"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5rp4-749p-vx26","url":"https://osv.dev/vulnerability/GHSA-5rp4-749p-vx26"}],"summary":"Apache Airflow vulnerable to Use of Externally-Controlled Format String"}