{"action":"Upgrade ascii to 0.9.3 or later.","affected":[{"fixed":"0.9.3","introduced":"0.7.0"}],"component":"ascii","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.9.3"],"ghsa_id":"GHSA-mrrw-grhq-86gf","id":"tcs_01M5KF1TMG9K0Y0XYGVJ5ZRSAY","modified_at":"2026-07-16T19:00:21.951703667Z","published_at":"2023-02-28T20:30:10Z","references":["https://osv.dev/vulnerability/GHSA-mrrw-grhq-86gf","https://github.com/tomprogrammer/rust-ascii/issues/64","https://github.com/tomprogrammer/rust-ascii/pull/63/commits/8a6c7798c202766bd57d70fb8d12739dd68fb9dc","https://github.com/tomprogrammer/rust-ascii","https://rustsec.org/advisories/RUSTSEC-2023-0015.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-mrrw-grhq-86gf","url":"https://osv.dev/vulnerability/GHSA-mrrw-grhq-86gf"}],"summary":"Ascii (crate) allows out-of-bounds array indexing in safe code"}