{"action":"Upgrade ckeditor/ckeditor to 4.24.0 or later.","affected":[{"fixed":"4.24.0","introduced":"0"}],"component":"ckeditor/ckeditor","cve_ids":["CVE-2024-24815"],"ecosystem":"Packagist","epss":0.00706,"exploited":false,"fixed_versions":["4.24.0"],"ghsa_id":"GHSA-fq6h-4g8v-qqvm","id":"tcs_01M5KF1ZB0CRE4CGHREV8MDVTV","modified_at":"2026-09-10T03:50:06.171222645Z","published_at":"2024-02-07T17:30:37Z","references":["https://osv.dev/vulnerability/GHSA-fq6h-4g8v-qqvm","https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-fq6h-4g8v-qqvm","https://nvd.nist.gov/vuln/detail/CVE-2024-24815","https://github.com/ckeditor/ckeditor4/commit/8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb","https://ckeditor.com/docs/ckeditor4/latest/api/CKEDITOR_dtd.html#property-S-cdata","https://ckeditor.com/docs/ckeditor4/latest/features/fullpage.html","https://ckeditor.com/docs/ckeditor4/latest/guide/dev_advanced_content_filter.html","https://github.com/ckeditor/ckeditor4","https://www.drupal.org/sa-contrib-2024-009"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-fq6h-4g8v-qqvm#Packagist/ckeditor/ckeditor","url":"https://osv.dev/vulnerability/GHSA-fq6h-4g8v-qqvm"}],"summary":"CKEditor4 Cross-site Scripting vulnerability caused by incorrect CDATA detection"}