{"action":"Upgrade toodee to 0.6.0 or later.","affected":[{"fixed":"0.6.0","introduced":"0.2.0"}],"component":"toodee","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.6.0"],"ghsa_id":"GHSA-pfp7-vxgr-83pw","id":"tcs_01M5KF22RC4WZJEJREVHEMN17X","modified_at":"2025-10-28T06:29:25.567885Z","published_at":"2025-09-09T15:23:43Z","references":["https://osv.dev/vulnerability/GHSA-pfp7-vxgr-83pw","https://github.com/antonmarsden/toodee/issues/26","https://github.com/antonmarsden/toodee/commit/e6e16d5a97e6258ffbedbae1bde65b45c60f242f","https://github.com/antonmarsden/toodee","https://rustsec.org/advisories/RUSTSEC-2025-0062.html"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-pfp7-vxgr-83pw","url":"https://osv.dev/vulnerability/GHSA-pfp7-vxgr-83pw"}],"summary":"toodee is vulnerable to Heap Buffer Overflow through its DrainCol Destructor"}