{"action":"Upgrade tensorflow-gpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-37657"],"ecosystem":"PyPI","epss":0.00167,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-5xwc-mrhx-5g3m","id":"tcs_01M5KF22X3ACRYN92B7RZ6HYFG","modified_at":"2026-07-08T06:29:02.236832841Z","published_at":"2021-08-25T14:42:52Z","references":["https://osv.dev/vulnerability/GHSA-5xwc-mrhx-5g3m","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5xwc-mrhx-5g3m","https://nvd.nist.gov/vuln/detail/CVE-2021-37657","https://github.com/tensorflow/tensorflow/commit/f2a673bd34f0d64b8e40a551ac78989d16daad09","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-570.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-768.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-279.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-5xwc-mrhx-5g3m#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-5xwc-mrhx-5g3m"}],"summary":"Reference binding to nullptr in `MatrixDiagV*` ops"}