{"action":"Upgrade pocketmine/pocketmine-mp to 4.2.9 or later.","affected":[{"fixed":"4.2.9","introduced":"0"}],"component":"pocketmine/pocketmine-mp","cve_ids":["CVE-2022-51012"],"ecosystem":"Packagist","epss":0.0053,"exploited":false,"fixed_versions":["4.2.9"],"ghsa_id":"GHSA-g5rr-p69h-7v3g","id":"tcs_01M5KF2CKV2289B52YGTWFJ0DS","modified_at":"2026-09-08T12:38:04.306639606Z","published_at":"2022-04-22T20:57:12Z","references":["https://osv.dev/vulnerability/GHSA-g5rr-p69h-7v3g","https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g5rr-p69h-7v3g","https://github.com/pmmp/PocketMine-MP/commit/5a98b08ee8dc8ff14862cd83d2e4af9d212fefc2","https://github.com/pmmp/PocketMine-MP","https://github.com/pmmp/PocketMine-MP/blob/4.2.9/changelogs/4.2.md#429","https://github.com/pmmp/PocketMine-MP/releases/tag/4.2.9"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-g5rr-p69h-7v3g","url":"https://osv.dev/vulnerability/GHSA-g5rr-p69h-7v3g"}],"summary":"Insufficient type validation in pocketmine/pocketmine-mp"}