{"action":"Upgrade jupyter-server to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"}],"component":"jupyter-server","cve_ids":["CVE-2023-40170"],"ecosystem":"PyPI","epss":0.00623,"exploited":false,"fixed_versions":["2.7.2"],"ghsa_id":"GHSA-64x5-55rw-9974","id":"tcs_01M5KF2EEWAZS5VWFT6JPXAPA6","modified_at":"2026-09-10T03:49:57.417478394Z","published_at":"2023-08-29T23:34:09Z","references":["https://osv.dev/vulnerability/GHSA-64x5-55rw-9974","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-64x5-55rw-9974","https://nvd.nist.gov/vuln/detail/CVE-2023-40170","https://github.com/jupyter-server/jupyter_server/commit/87a4927272819f0b1cae1afa4c8c86ee2da002fd","https://github.com/jupyter-server/jupyter_server","https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-server/PYSEC-2023-157.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NRP7DNZYVOIA4ZB3U3ZWKTFZEPYWNGCQ","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XDKQAWQN6SQTOVACZNXYKEHWQXGG4DOF"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-64x5-55rw-9974","url":"https://osv.dev/vulnerability/GHSA-64x5-55rw-9974"}],"summary":"cross-site inclusion (XSSI) of files in jupyter-server"}