{"action":"Upgrade apollo-router to 1.45.1 or later.","affected":[{"fixed":"1.45.1","introduced":"1.44.0"}],"component":"apollo-router","cve_ids":["CVE-2024-32971"],"ecosystem":"crates.io","epss":0.00727,"exploited":false,"fixed_versions":["1.45.1"],"ghsa_id":"GHSA-q9p4-hw9m-fj2v","id":"tcs_01M5KF2GG4X7SM58V5P7B1QMSC","modified_at":"2026-09-10T03:50:14.171560561Z","published_at":"2024-05-02T08:20:00Z","references":["https://osv.dev/vulnerability/GHSA-q9p4-hw9m-fj2v","https://github.com/apollographql/router/security/advisories/GHSA-q9p4-hw9m-fj2v","https://nvd.nist.gov/vuln/detail/CVE-2024-32971","https://github.com/apollographql/router/commit/ff9f666598cd17661880fe7fc6e9c9611316e529","https://github.com/apollographql/router","https://github.com/apollographql/router/releases/tag/v1.45.1","https://www.apollographql.com/docs/router/configuration/distributed-caching/#distributed-query-plan-caching"],"severity":{"label":"critical","score":9},"sources":[{"source":"osv","source_id":"GHSA-q9p4-hw9m-fj2v","url":"https://osv.dev/vulnerability/GHSA-q9p4-hw9m-fj2v"}],"summary":"Apollo Router vulnerable to Critical Regression In Query Plan Cache"}