{"action":"Upgrade ansible to 1.6.4 or later.","affected":[{"fixed":"1.6.4","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2014-4678"],"ecosystem":"PyPI","epss":0.0524,"exploited":false,"fixed_versions":["1.6.4"],"ghsa_id":"GHSA-66c7-5pwv-mm3j","id":"tcs_01M5KF2KVQEPM99FRRKD3E7783","modified_at":"2024-09-10T22:31:14.077390Z","published_at":"2022-05-24T22:01:18Z","references":["https://osv.dev/vulnerability/GHSA-66c7-5pwv-mm3j","https://nvd.nist.gov/vuln/detail/CVE-2014-4678","https://github.com/ansible/ansible/commit/5429b85b9f6c2e640074176f36ff05fd5e4d1916","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-203.yaml","https://groups.google.com/forum/message/raw?msg=ansible-announce/ieV1vZvcTXU/5Q93ThkY9rIJ","https://security-tracker.debian.org/tracker/CVE-2014-4678","https://www.openwall.com/lists/oss-security/2014/06/26/30","https://www.openwall.com/lists/oss-security/2014/07/02/2","https://www.rapid7.com/db/vulnerabilities/freebsd-vid-2c493ac8-205e-11e5-a4a5-002590263bf5","https://www.rapid7.com/db/vulnerabilities/gentoo-linux-cve-2014-4678"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-66c7-5pwv-mm3j","url":"https://osv.dev/vulnerability/GHSA-66c7-5pwv-mm3j"}],"summary":"Ansible Code Injection Vulnerability"}