{"action":"Upgrade postcss to 7.0.36 or later.","affected":[{"fixed":"8.2.13","introduced":"8.0.0"},{"fixed":"7.0.36","introduced":"0"}],"component":"postcss","cve_ids":["CVE-2021-23382"],"ecosystem":"npm","epss":0.02557,"exploited":false,"fixed_versions":["8.2.13","7.0.36"],"ghsa_id":"GHSA-566m-qj78-rww5","id":"tcs_01M5KF2SDX188GP2K2H64R4QWW","modified_at":"2025-01-14T08:57:01.148991Z","published_at":"2022-01-07T00:21:36Z","references":["https://osv.dev/vulnerability/GHSA-566m-qj78-rww5","https://nvd.nist.gov/vuln/detail/CVE-2021-23382","https://github.com/postcss/postcss/commit/2b1d04c867995e55124e0a165b7c6622c1735956","https://github.com/postcss/postcss/releases/tag/7.0.36","https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1255641","https://snyk.io/vuln/SNYK-JS-POSTCSS-1255640"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-566m-qj78-rww5","url":"https://osv.dev/vulnerability/GHSA-566m-qj78-rww5"}],"summary":"Regular Expression Denial of Service in postcss"}