{"action":"Upgrade moodle/moodle to 4.1.10 or later.","affected":[{"fixed":"4.3.4","introduced":"4.3.0"},{"fixed":"4.2.7","introduced":"4.2.0"},{"fixed":"4.1.10","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-34001"],"ecosystem":"Packagist","epss":0.00401,"exploited":false,"fixed_versions":["4.3.4","4.2.7","4.1.10"],"ghsa_id":"GHSA-gq9f-8rj4-w7jc","id":"tcs_01M5KF30PQFHZA72NYY8NBGV58","modified_at":"2025-05-31T06:27:01.647275Z","published_at":"2024-05-31T21:30:54Z","references":["https://osv.dev/vulnerability/GHSA-gq9f-8rj4-w7jc","https://nvd.nist.gov/vuln/detail/CVE-2024-34001","https://github.com/moodle/moodle/commit/03e93da556201291e4a345d353a06d08d5d04dd6","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=458389"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"GHSA-gq9f-8rj4-w7jc","url":"https://osv.dev/vulnerability/GHSA-gq9f-8rj4-w7jc"}],"summary":"Moodle CSRF risk in admin preset tool management of presets"}