{"action":"Upgrade ansible to 2.6.20 or later.","affected":[{"fixed":"2.8.6","introduced":"2.8.0"},{"fixed":"2.7.14","introduced":"2.7.0"},{"fixed":"2.6.20","introduced":"2.6.0"}],"component":"ansible","cve_ids":["CVE-2019-14856"],"ecosystem":"PyPI","epss":0.01663,"exploited":false,"fixed_versions":["2.8.6","2.7.14","2.6.20"],"ghsa_id":"GHSA-6fq2-x65v-v9h7","id":"tcs_01M5KF37T43WVF7FE3E3K31V1J","modified_at":"2024-11-24T05:23:43.447688Z","published_at":"2022-05-24T17:02:07Z","references":["https://osv.dev/vulnerability/GHSA-6fq2-x65v-v9h7","https://nvd.nist.gov/vuln/detail/CVE-2019-14856","https://github.com/ansible/ansible/pull/63351","https://github.com/ansible/ansible/commit/16684f118715a52e1c46d437652add9ca36423de","https://github.com/ansible/ansible/commit/2cbd8775ca1271195169f62122df1f88b532e74f","https://github.com/ansible/ansible/commit/40618d70e61af1123907a5fb246cc4fd35f1e5c3","https://github.com/ansible/ansible/commit/7f4befdea77045fa83b5f2b304bd5e16b219f74c","https://access.redhat.com/errata/RHSA-2020:0756","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14856","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-146.yaml","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-6fq2-x65v-v9h7","url":"https://osv.dev/vulnerability/GHSA-6fq2-x65v-v9h7"}],"summary":"Ansible password prompts could expose passwords"}