{"action":"Upgrade obfstr to 0.4.4 or later.","affected":[{"fixed":"0.4.4","introduced":"0"}],"component":"obfstr","cve_ids":["CVE-2024-58253"],"ecosystem":"crates.io","epss":0.00168,"exploited":false,"fixed_versions":["0.4.4"],"ghsa_id":"GHSA-v2p5-q653-9j99","id":"tcs_01M5KF39FVX8Q3R43FZ2B5D5M4","modified_at":"2025-05-05T17:44:19.213512Z","published_at":"2025-05-02T21:30:43Z","references":["https://osv.dev/vulnerability/GHSA-v2p5-q653-9j99","https://nvd.nist.gov/vuln/detail/CVE-2024-58253","https://github.com/CasualX/obfstr/issues/60","https://github.com/CasualX/obfstr","https://github.com/CasualX/obfstr/compare/v0.4.3...v0.4.4"],"severity":{"label":"low","score":2.9},"sources":[{"source":"osv","source_id":"GHSA-v2p5-q653-9j99","url":"https://osv.dev/vulnerability/GHSA-v2p5-q653-9j99"}],"summary":"obfstr Type Confusion vulnerability"}