{"action":"Upgrade websockets to 5.0 or later.","affected":[{"fixed":"5.0","introduced":"4.0"}],"component":"websockets","cve_ids":["CVE-2018-1000518"],"ecosystem":"PyPI","epss":0.01833,"exploited":false,"fixed_versions":["5.0"],"ghsa_id":"GHSA-6g87-ff9q-v847","id":"tcs_01M5KF3A88ECJAM0Z90D5GVH11","modified_at":"2024-11-19T18:23:42.891487Z","published_at":"2018-09-17T20:46:52Z","references":["https://osv.dev/vulnerability/GHSA-6g87-ff9q-v847","https://nvd.nist.gov/vuln/detail/CVE-2018-1000518","https://github.com/aaugustin/websockets/pull/407","https://github.com/aaugustin/websockets","https://github.com/pypa/advisory-database/tree/main/vulns/websockets/PYSEC-2018-79.yaml"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6g87-ff9q-v847","url":"https://osv.dev/vulnerability/GHSA-6g87-ff9q-v847"}],"summary":"websockets is vulnerable to denial of service by memory exhaustion"}