{"action":"Upgrade bostr to 3.0.10 or later.","affected":[{"fixed":"3.0.10","introduced":"0"}],"component":"bostr","cve_ids":["CVE-2024-41962"],"ecosystem":"npm","epss":0.00297,"exploited":false,"fixed_versions":["3.0.10"],"ghsa_id":"GHSA-5cf7-cxrf-mq73","id":"tcs_01M5KF3AZKHV8HNKSF7DSP7PXS","modified_at":"2024-08-02T16:02:10Z","published_at":"2024-08-02T01:20:13Z","references":["https://osv.dev/vulnerability/GHSA-5cf7-cxrf-mq73","https://github.com/Yonle/bostr/security/advisories/GHSA-5cf7-cxrf-mq73","https://nvd.nist.gov/vuln/detail/CVE-2024-41962","https://github.com/Yonle/bostr/commit/49181f4ec9ae1472c6675cab56bbc01e723855af","https://github.com/Yonle/bostr","https://github.com/Yonle/bostr/blob/8665374a66e2afb9f92d0414b0d6f420a95d5d2d/auth.js#L21","https://github.com/Yonle/bostr/releases/tag/3.0.10"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-5cf7-cxrf-mq73","url":"https://osv.dev/vulnerability/GHSA-5cf7-cxrf-mq73"}],"summary":"Bostr Improper Authorization vulnerability"}