{"action":"Upgrade teddy to 0.5.9 or later.","affected":[{"fixed":"0.5.9","introduced":"0"}],"component":"teddy","cve_ids":["CVE-2021-23447"],"ecosystem":"npm","epss":0.01128,"exploited":false,"fixed_versions":["0.5.9"],"ghsa_id":"GHSA-5f38-9jw2-6r6h","id":"tcs_01M5KF3D19QWAZ9XX9D7P36BQ2","modified_at":"2026-07-08T06:49:51.584010565Z","published_at":"2021-10-12T16:22:04Z","references":["https://osv.dev/vulnerability/GHSA-5f38-9jw2-6r6h","https://nvd.nist.gov/vuln/detail/CVE-2021-23447","https://github.com/rooseveltframework/teddy/pull/518","https://github.com/rooseveltframework/teddy/commit/64c556717b4879bf8d4c30067cf6e70d899a3dc0","https://github.com/rooseveltframework/teddy","https://github.com/rooseveltframework/teddy/releases/tag/0.5.9","https://snyk.io/vuln/SNYK-JS-TEDDY-1579557"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-5f38-9jw2-6r6h","url":"https://osv.dev/vulnerability/GHSA-5f38-9jw2-6r6h"}],"summary":"Cross-site Scripting in teddy"}