{"action":"Upgrade swagger-typescript-api to 13.12.2 or later.","affected":[{"fixed":"13.12.2","introduced":"0"}],"component":"swagger-typescript-api","cve_ids":["CVE-2026-54664"],"ecosystem":"npm","epss":0.00477,"exploited":false,"fixed_versions":["13.12.2"],"ghsa_id":"GHSA-5f94-x226-ccpm","id":"tcs_01M5KF3EVA76BK40F40VD6DQSM","modified_at":"2026-07-29T14:56:42.591024Z","published_at":"2026-07-29T14:33:00Z","references":["https://osv.dev/vulnerability/GHSA-5f94-x226-ccpm","https://github.com/acacode/swagger-typescript-api/security/advisories/GHSA-5f94-x226-ccpm","https://github.com/acacode/swagger-typescript-api/pull/1779","https://github.com/acacode/swagger-typescript-api/commit/306d59acb8ffbb00f953f807b97234b21f51d9de","https://github.com/acacode/swagger-typescript-api","https://github.com/acacode/swagger-typescript-api/releases/tag/v13.12.2"],"severity":{"label":"high","score":8.3},"sources":[{"source":"osv","source_id":"GHSA-5f94-x226-ccpm","url":"https://osv.dev/vulnerability/GHSA-5f94-x226-ccpm"}],"summary":"swagger-typescript-api vulnerable to code injection via unescaped enum string values"}