{"action":"Upgrade ansible-runner to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"ansible-runner","cve_ids":["CVE-2021-4041"],"ecosystem":"PyPI","epss":0.00332,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-6j58-grhv-2769","id":"tcs_01M5KF3JPAJ3YBBKRC5EZ8C7CJ","modified_at":"2024-09-03T21:37:16.179658Z","published_at":"2022-08-25T00:00:27Z","references":["https://osv.dev/vulnerability/GHSA-6j58-grhv-2769","https://nvd.nist.gov/vuln/detail/CVE-2021-4041","https://github.com/ansible/ansible-runner/commit/3533f265f4349a3f2a0283158cd01b59a6bbc7bd","https://access.redhat.com/security/cve/CVE-2021-4041","https://bugzilla.redhat.com/show_bug.cgi?id=2028074","https://github.com/advisories/GHSA-6j58-grhv-2769","https://github.com/ansible/ansible-runner","https://github.com/pypa/advisory-database/tree/main/vulns/ansible-runner/PYSEC-2022-253.yaml"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-6j58-grhv-2769","url":"https://osv.dev/vulnerability/GHSA-6j58-grhv-2769"}],"summary":"ansible-runner vulnerable to shell command injection"}