{"action":"Upgrade github.com/temporalio/ui-server/v2 to 2.25.0 or later.","affected":[{"fixed":"2.25.0","introduced":"0"}],"component":"github.com/temporalio/ui-server/v2","cve_ids":["CVE-2024-2435"],"ecosystem":"Go","epss":0.00394,"exploited":false,"fixed_versions":["2.25.0"],"ghsa_id":"GHSA-8f25-w7qj-r7hc","id":"tcs_01M5KF3K3G5AXS9TX6XWHH324G","modified_at":"2026-09-10T03:50:12.506459590Z","published_at":"2024-04-02T18:31:16Z","references":["https://osv.dev/vulnerability/GHSA-8f25-w7qj-r7hc","https://nvd.nist.gov/vuln/detail/CVE-2024-2435","https://github.com/temporalio/ui-server","https://github.com/temporalio/ui-server/releases/tag/v2.25.0"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-8f25-w7qj-r7hc","url":"https://osv.dev/vulnerability/GHSA-8f25-w7qj-r7hc"}],"summary":"Temporal UI Server cross-site scripting vulnerability"}