{"action":"Upgrade drupal/tfa to 1.10.0 or later.","affected":[{"fixed":"1.10.0","introduced":"0"}],"component":"drupal/tfa","cve_ids":["CVE-2025-31694"],"ecosystem":"Packagist","epss":0.004,"exploited":false,"fixed_versions":["1.10.0"],"ghsa_id":"GHSA-hf6c-fgp3-jfch","id":"tcs_01M5KF3KJ99E26AWKRK45Q1V2G","modified_at":"2025-12-10T23:41:12.396550Z","published_at":"2025-04-01T00:30:35Z","references":["https://osv.dev/vulnerability/GHSA-hf6c-fgp3-jfch","https://nvd.nist.gov/vuln/detail/CVE-2025-31694","https://git.drupalcode.org/project/tfa","https://www.drupal.org/sa-contrib-2025-023"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-hf6c-fgp3-jfch","url":"https://osv.dev/vulnerability/GHSA-hf6c-fgp3-jfch"}],"summary":"Drupal Two-factor Authentication (TFA) Vulnerable to Forceful Browsing"}