{"action":"Upgrade whoami to 1.5.0 or later.","affected":[{"fixed":"1.5.0","introduced":"0.5.3"}],"component":"whoami","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["1.5.0"],"ghsa_id":"GHSA-w5w5-8vfh-xcjq","id":"tcs_01M5KF3WT7F1V7SGGAHZ2AX0TE","modified_at":"2024-04-11T16:41:43.737392Z","published_at":"2024-04-05T15:39:19Z","references":["https://osv.dev/vulnerability/GHSA-w5w5-8vfh-xcjq","https://github.com/ardaku/whoami/issues/91","https://github.com/ardaku/whoami/commit/d6ee13ed9e818aa51b8d86d95e8009a376289a40","https://github.com/ardaku/whoami","https://rustsec.org/advisories/RUSTSEC-2024-0020.html"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"GHSA-w5w5-8vfh-xcjq","url":"https://osv.dev/vulnerability/GHSA-w5w5-8vfh-xcjq"}],"summary":"whoami stack buffer overflow on several Unix platforms"}