{"action":"Upgrade apache-airflow to 2.4.0 or later.","affected":[{"fixed":"2.4.0","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2022-40127"],"ecosystem":"PyPI","epss":0.85653,"exploited":false,"fixed_versions":["2.4.0"],"ghsa_id":"GHSA-6pw3-8h9w-32gc","id":"tcs_01M5KF3XQBPS7R9Q1J082T1PVK","modified_at":"2025-05-01T13:37:00.376202Z","published_at":"2022-11-14T12:00:15Z","references":["https://osv.dev/vulnerability/GHSA-6pw3-8h9w-32gc","https://nvd.nist.gov/vuln/detail/CVE-2022-40127","https://github.com/apache/airflow/pull/25960","https://github.com/apache/airflow/commit/372e699c2d1e11f7087b5340454d0a0a6a56fbf5","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-42982.yaml","https://lists.apache.org/thread/cf132hgm6jvzvsbpsozl3plf1r4cwysy","http://www.openwall.com/lists/oss-security/2022/11/14/2"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-6pw3-8h9w-32gc","url":"https://osv.dev/vulnerability/GHSA-6pw3-8h9w-32gc"}],"summary":"Apache Airflow vulnerable to OS Command Injection via example DAGs"}