{"action":"Upgrade vyper to 0.3.8 or later.","affected":[{"fixed":"0.3.8","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2023-32058"],"ecosystem":"PyPI","epss":0.00913,"exploited":false,"fixed_versions":["0.3.8"],"ghsa_id":"GHSA-6r8q-pfpv-7cgj","id":"tcs_01M5KF4220T4HJCMJFZG3VWKPN","modified_at":"2026-09-10T03:50:01.254556464Z","published_at":"2023-05-12T20:21:35Z","references":["https://osv.dev/vulnerability/GHSA-6r8q-pfpv-7cgj","https://github.com/vyperlang/vyper/security/advisories/GHSA-6r8q-pfpv-7cgj","https://nvd.nist.gov/vuln/detail/CVE-2023-32058","https://github.com/vyperlang/vyper/commit/3de1415ee77a9244eb04bdb695e249d3ec9ed868","https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2023-78.yaml","https://github.com/vyperlang/vyper"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6r8q-pfpv-7cgj","url":"https://osv.dev/vulnerability/GHSA-6r8q-pfpv-7cgj"}],"summary":"Vyper vulnerable to integer overflow in loop"}