{"action":"Upgrade glib to 0.20.0 or later.","affected":[{"fixed":"0.20.0","introduced":"0.15.0"}],"component":"glib","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.20.0"],"ghsa_id":"GHSA-wrw7-89jp-8q8g","id":"tcs_01M5KF47WT13W3XPY2V72VT5G0","modified_at":"2025-10-28T06:29:26.473225Z","published_at":"2024-12-23T20:19:24Z","references":["https://osv.dev/vulnerability/GHSA-wrw7-89jp-8q8g","https://github.com/gtk-rs/gtk-rs-core/pull/1343","https://github.com/gtk-rs/gtk-rs-core","https://rustsec.org/advisories/RUSTSEC-2024-0429.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-wrw7-89jp-8q8g","url":"https://osv.dev/vulnerability/GHSA-wrw7-89jp-8q8g"}],"summary":"Unsoundness in `Iterator` and `DoubleEndedIterator` impls for `glib::VariantStrIter`"}