{"action":"Upgrade mercurial to 3.2.3 or later.","affected":[{"fixed":"3.2.3","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2014-9390"],"ecosystem":"PyPI","epss":0.75597,"exploited":false,"fixed_versions":["3.2.3"],"ghsa_id":"GHSA-6vvc-c2m3-cjf3","id":"tcs_01M5KF48F63B530FXZRZ03PKYD","modified_at":"2024-09-25T20:01:24.028730Z","published_at":"2022-05-17T19:57:29Z","references":["https://osv.dev/vulnerability/GHSA-6vvc-c2m3-cjf3","https://nvd.nist.gov/vuln/detail/CVE-2014-9390","https://github.com/libgit2/libgit2/commit/928429c5c96a701bcbcafacb2421a82602b36915","https://github.com/blog/1938-git-client-vulnerability-announced","https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2020-217.yaml","https://libgit2.org/security","https://news.ycombinator.com/item?id=8769667","https://projects.eclipse.org/projects/technology.jgit/releases/3.5.3","https://web.archive.org/web/20211204220400/https://securitytracker.com/id?1031404","http://article.gmane.org/gmane.linux.kernel/1853266","http://git-blame.blogspot.com/2014/12/git-1856-195-205-214-and-221-and.html","http://mercurial.selenic.com/wiki/WhatsNew","http://securitytracker.com/id?1031404","http://support.apple.com/kb/HT204147"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-6vvc-c2m3-cjf3","url":"https://osv.dev/vulnerability/GHSA-6vvc-c2m3-cjf3"}],"summary":"JGit Improper Input Validation vulnerability"}