{"action":"Upgrade saml2-js to 1.12.4 or later.","affected":[{"fixed":"1.12.4","introduced":"0"},{"fixed":"2.0.2","introduced":"2.0.0"}],"component":"saml2-js","cve_ids":["CVE-2017-11429"],"ecosystem":"npm","epss":0.02741,"exploited":false,"fixed_versions":["1.12.4","2.0.2"],"ghsa_id":"GHSA-5p5w-j3g7-w4wv","id":"tcs_01M5KF49629CRVH4PD05QCNQAA","modified_at":"2023-11-08T03:58:49.417767Z","published_at":"2019-07-05T21:11:18Z","references":["https://osv.dev/vulnerability/GHSA-5p5w-j3g7-w4wv","https://nvd.nist.gov/vuln/detail/CVE-2017-11429","https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations","https://github.com/advisories/GHSA-5p5w-j3g7-w4wv","https://www.kb.cert.org/vuls/id/475445","https://www.npmjs.com/advisories/567"],"severity":{"label":"high","score":7.7},"sources":[{"source":"osv","source_id":"GHSA-5p5w-j3g7-w4wv","url":"https://osv.dev/vulnerability/GHSA-5p5w-j3g7-w4wv"}],"summary":"Authentication bypass via incorrect XML canonicalization and DOM traversal in saml2-js"}