{"action":"Upgrade deepseek-tui to 0.8.23 or later.","affected":[{"fixed":"0.8.23","introduced":"0.3.0"}],"component":"deepseek-tui","cve_ids":["CVE-2026-45311"],"ecosystem":"npm","epss":0.00498,"exploited":false,"fixed_versions":["0.8.23"],"ghsa_id":"GHSA-wx44-2q6h-j6p8","id":"tcs_01M5KF4C7MECKRCFZF0PDAZMRH","modified_at":"2026-06-09T10:30:13.948106433Z","published_at":"2026-05-14T20:29:33Z","references":["https://osv.dev/vulnerability/GHSA-wx44-2q6h-j6p8","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wx44-2q6h-j6p8","https://github.com/Hmbown/DeepSeek-TUI/security/advisories/GHSA-wx44-2q6h-j6p8","https://nvd.nist.gov/vuln/detail/CVE-2026-45311","https://github.com/Hmbown/DeepSeek-TUI","https://github.com/Hmbown/DeepSeek-TUI/releases/tag/v0.8.23"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"GHSA-wx44-2q6h-j6p8#npm/deepseek-tui","url":"https://osv.dev/vulnerability/GHSA-wx44-2q6h-j6p8"}],"summary":"DeepSeek TUI: run_tests Tool Enables RCE via Malicious Repository Without Approval"}