{"action":"Upgrade apollo-router to 1.52.1 or later.","affected":[{"fixed":"1.52.1","introduced":"1.7.0"}],"component":"apollo-router","cve_ids":["CVE-2024-43783"],"ecosystem":"crates.io","epss":0.00857,"exploited":false,"fixed_versions":["1.52.1"],"ghsa_id":"GHSA-x6xq-whh3-gg32","id":"tcs_01M5KF4M4GS108NYW405Z87YP5","modified_at":"2024-08-27T20:31:40Z","published_at":"2024-08-27T18:14:29Z","references":["https://osv.dev/vulnerability/GHSA-x6xq-whh3-gg32","https://github.com/apollographql/router/security/advisories/GHSA-x6xq-whh3-gg32","https://nvd.nist.gov/vuln/detail/CVE-2024-43783","https://github.com/apollographql/router/commit/7a9c020608a62dcaa306b72ed0f6980f15923b14","https://github.com/apollographql/router","https://github.com/apollographql/router/releases/tag/v1.52.1","https://www.apollographql.com/docs/router/configuration/overview/#request-limits","https://www.apollographql.com/docs/router/customizations/coprocessor","https://www.apollographql.com/docs/router/customizations/native"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-x6xq-whh3-gg32","url":"https://osv.dev/vulnerability/GHSA-x6xq-whh3-gg32"}],"summary":"Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies"}