{"action":"Upgrade poetry to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"}],"component":"poetry","cve_ids":["CVE-2026-41140"],"ecosystem":"PyPI","epss":0.00294,"exploited":false,"fixed_versions":["2.3.4"],"ghsa_id":"GHSA-73h3-mf4w-8647","id":"tcs_01M5KF4NQEKQT16BSNRYY4WNSZ","modified_at":"2026-07-13T16:42:25.945183494Z","published_at":"2026-04-22T14:35:30Z","references":["https://osv.dev/vulnerability/GHSA-73h3-mf4w-8647","https://github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647","https://nvd.nist.gov/vuln/detail/CVE-2026-41140","https://github.com/python-poetry/poetry","https://github.com/python-poetry/poetry/releases/tag/2.3.4"],"severity":{"label":"high","score":8.7},"sources":[{"source":"osv","source_id":"GHSA-73h3-mf4w-8647","url":"https://osv.dev/vulnerability/GHSA-73h3-mf4w-8647"},{"source":"nvd","source_id":"CVE-2026-41140","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-41140"}],"summary":"Poetry has Path Traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4"}