{"action":"Upgrade cassandra-cpp to 3.0.0 or later.","affected":[{"fixed":"3.0.0","introduced":"0"}],"component":"cassandra-cpp","cve_ids":["CVE-2024-27284"],"ecosystem":"crates.io","epss":0.00817,"exploited":false,"fixed_versions":["3.0.0"],"ghsa_id":"GHSA-x9xc-63hg-vcfq","id":"tcs_01M5KF4NV6NXH5PB78TRE90JK5","modified_at":"2026-09-10T03:50:12.870705707Z","published_at":"2024-04-05T15:00:55Z","references":["https://osv.dev/vulnerability/GHSA-x9xc-63hg-vcfq","https://github.com/Metaswitch/cassandra-rs/security/advisories/GHSA-x9xc-63hg-vcfq","https://nvd.nist.gov/vuln/detail/CVE-2024-27284","https://github.com/Metaswitch/cassandra-rs/commit/ae054dc8044eac9c2c7ae2b1ab154b53ca7f8df7","https://github.com/Metaswitch/cassandra-rs","https://rustsec.org/advisories/RUSTSEC-2024-0017.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-x9xc-63hg-vcfq","url":"https://osv.dev/vulnerability/GHSA-x9xc-63hg-vcfq"}],"summary":"cassandra-rs's non-idiomatic use of iterators leads to use after free"}