{"action":"Upgrade ws to 1.1.5 or later.","affected":[{"fixed":"1.1.5","introduced":"0.6.0"},{"fixed":"3.3.1","introduced":"2.0.0"}],"component":"ws","cve_ids":[],"ecosystem":"npm","exploited":false,"fixed_versions":["1.1.5","3.3.1"],"ghsa_id":"GHSA-5v72-xg48-5rpm","id":"tcs_01M5KF4Q7HWKBE8X98CQTHD8PA","modified_at":"2026-07-17T18:45:52.881635162Z","published_at":"2019-06-04T19:37:52Z","references":["https://osv.dev/vulnerability/GHSA-5v72-xg48-5rpm","https://github.com/websockets/ws/commit/a810bfa44f08c84ff3f43cc71327e9bb5fb273ef","https://github.com/websockets/ws/commit/c4fe46608acd61fbf7397eadc47378903f95b78a","https://github.com/websockets/ws/commit/f8fdcd40ac8be7318a6ee41f5ceb7e77c995b407","https://github.com/websockets/ws","https://snyk.io/vuln/npm:ws:20171108"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5v72-xg48-5rpm","url":"https://osv.dev/vulnerability/GHSA-5v72-xg48-5rpm"}],"summary":"Denial of Service in ws"}