{"action":"Upgrade tiny-secp256k1 to 1.1.7 or later.","affected":[{"fixed":"1.1.7","introduced":"0"}],"component":"tiny-secp256k1","cve_ids":["CVE-2024-49365"],"ecosystem":"npm","epss":0.00247,"exploited":false,"fixed_versions":["1.1.7"],"ghsa_id":"GHSA-5vhg-9xg4-cv9m","id":"tcs_01M5KF4RZS9BR2GBTFZW2F3HBF","modified_at":"2025-07-01T13:13:38Z","published_at":"2025-06-30T17:44:14Z","references":["https://osv.dev/vulnerability/GHSA-5vhg-9xg4-cv9m","https://github.com/bitcoinjs/tiny-secp256k1/security/advisories/GHSA-5vhg-9xg4-cv9m","https://nvd.nist.gov/vuln/detail/CVE-2024-49365","https://github.com/bitcoinjs/tiny-secp256k1/pull/140","https://github.com/bitcoinjs/tiny-secp256k1"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-5vhg-9xg4-cv9m","url":"https://osv.dev/vulnerability/GHSA-5vhg-9xg4-cv9m"},{"source":"nvd","source_id":"CVE-2024-49365","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-49365"}],"summary":"tiny-secp256k1 allows for verify() bypass when running in bundled environment"}