{"action":"Upgrade @openzeppelin/contracts-upgradeable to 4.3.2 or later.","affected":[{"fixed":"4.3.2","introduced":"4.1.0"}],"component":"@openzeppelin/contracts-upgradeable","cve_ids":["CVE-2021-41264"],"ecosystem":"npm","epss":0.01487,"exploited":false,"fixed_versions":["4.3.2"],"ghsa_id":"GHSA-5vp3-v4hc-gx76","id":"tcs_01M5KF4T8JEDSRN05E183BCHAD","modified_at":"2026-07-08T06:27:43.429315395Z","published_at":"2021-09-15T20:23:17Z","references":["https://osv.dev/vulnerability/GHSA-5vp3-v4hc-gx76","https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76","https://nvd.nist.gov/vuln/detail/CVE-2021-41264","https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592","https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301","https://github.com/OpenZeppelin/openzeppelin-contracts"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-5vp3-v4hc-gx76#npm/@openzeppelin/contracts-upgradeable","url":"https://osv.dev/vulnerability/GHSA-5vp3-v4hc-gx76"}],"summary":"UUPSUpgradeable vulnerability in @openzeppelin/contracts"}