{"action":"Upgrade starlette to 0.25.0 or later.","affected":[{"fixed":"0.25.0","introduced":"0"}],"component":"starlette","cve_ids":["CVE-2023-30798"],"ecosystem":"PyPI","epss":0.01299,"exploited":false,"fixed_versions":["0.25.0"],"ghsa_id":"GHSA-74m5-2c7w-9w3x","id":"tcs_01M5KF4TD1MFRDTG3X5373VR2Y","modified_at":"2026-07-08T06:52:56.583902347Z","published_at":"2023-02-14T21:31:28Z","references":["https://osv.dev/vulnerability/GHSA-74m5-2c7w-9w3x","https://github.com/encode/starlette/security/advisories/GHSA-74m5-2c7w-9w3x","https://nvd.nist.gov/vuln/detail/CVE-2023-30798","https://github.com/encode/starlette/commit/8c74c2c8dba7030154f8af18e016136bea1938fa","https://github.com/encode/starlette","https://github.com/pypa/advisory-database/tree/main/vulns/starlette/PYSEC-2023-48.yaml","https://vulncheck.com/advisories/starlette-multipartparser-dos"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-74m5-2c7w-9w3x","url":"https://osv.dev/vulnerability/GHSA-74m5-2c7w-9w3x"}],"summary":"MultipartParser denial of service with too many fields or files"}