{"action":"Upgrade ansible to 2.5.15 or later.","affected":[{"fixed":"2.5.15","introduced":"0"},{"fixed":"2.6.14","introduced":"2.6.0a1"},{"fixed":"2.7.8","introduced":"2.7.0a1"}],"component":"ansible","cve_ids":["CVE-2019-3828"],"ecosystem":"PyPI","epss":0.00526,"exploited":false,"fixed_versions":["2.5.15","2.6.14","2.7.8"],"ghsa_id":"GHSA-74vq-h4q8-x6jv","id":"tcs_01M5KF4VVYHKSJ8Y4M4FWMZN98","modified_at":"2024-11-27T05:26:16.017948Z","published_at":"2019-04-15T16:19:19Z","references":["https://osv.dev/vulnerability/GHSA-74vq-h4q8-x6jv","https://nvd.nist.gov/vuln/detail/CVE-2019-3828","https://github.com/ansible/ansible/pull/52133","https://github.com/ansible/ansible/commit/396a2f74717477d80600450e2b7e45349d7b5110","https://github.com/ansible/ansible/commit/4be3215d2f9f84ca283895879f0c6ce1ed7dd333","https://github.com/ansible/ansible/commit/f3edc091523fbe301926b7a0db25fbbd96940d93","https://access.redhat.com/errata/RHSA-2019:3744","https://access.redhat.com/errata/RHSA-2019:3789","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3828","https://github.com/advisories/GHSA-74vq-h4q8-x6jv","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-5.yaml","https://usn.ubuntu.com/4072-1","http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html","http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html","http://packetstormsecurity.com/files/172837/Ansible-Fetch-Path-Traversal.html"],"severity":{"label":"medium","score":4.2},"sources":[{"source":"osv","source_id":"GHSA-74vq-h4q8-x6jv","url":"https://osv.dev/vulnerability/GHSA-74vq-h4q8-x6jv"}],"summary":"Ansible Path Traversal vulnerability"}