{"action":"Upgrade tensorflow to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow","cve_ids":["CVE-2021-29564"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-75f6-78jr-4656","id":"tcs_01M5KF4ZN3P8XDA3NQJKYG2N1Y","modified_at":"2026-07-08T06:27:31.320797670Z","published_at":"2021-05-21T14:25:08Z","references":["https://osv.dev/vulnerability/GHSA-75f6-78jr-4656","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-75f6-78jr-4656","https://nvd.nist.gov/vuln/detail/CVE-2021-29564","https://github.com/tensorflow/tensorflow/commit/f4c364a5d6880557f6f5b6eb5cee2c407f0186b3","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-492.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-690.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-201.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-75f6-78jr-4656","url":"https://osv.dev/vulnerability/GHSA-75f6-78jr-4656"}],"summary":"Null pointer dereference in `EditDistance`"}