{"action":"Upgrade openssl to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0.0.0-0"}],"component":"openssl","cve_ids":["CVE-2016-10931"],"ecosystem":"crates.io","epss":0.00745,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-34p9-f4q3-c4r7","id":"tcs_01M5KF51P9GCQ6XF81B000EN1Z","modified_at":"2026-02-04T04:25:11.291505Z","published_at":"2016-11-05T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2016-0001","https://crates.io/crates/openssl","https://rustsec.org/advisories/RUSTSEC-2016-0001.html","https://github.com/sfackler/rust-openssl/releases/tag/v0.9.0"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"RUSTSEC-2016-0001","url":"https://osv.dev/vulnerability/RUSTSEC-2016-0001"}],"summary":"SSL/TLS MitM vulnerability due to insecure defaults"}