{"action":"Upgrade hyper to 0.9.4 or later.","affected":[{"fixed":"0.9.4","introduced":"0.0.0-0"}],"component":"hyper","cve_ids":["CVE-2016-10932"],"ecosystem":"crates.io","epss":0.00738,"exploited":false,"fixed_versions":["0.9.4"],"ghsa_id":"GHSA-9xjr-m6f3-v5wm","id":"tcs_01M5KF51VPJME5Y46V3QF8PH76","modified_at":"2026-02-04T02:51:51.570285Z","published_at":"2016-05-09T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2016-0002","https://crates.io/crates/hyper","https://rustsec.org/advisories/RUSTSEC-2016-0002.html","https://github.com/hyperium/hyper/blob/master/CHANGELOG.md#v094-2016-05-09"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"RUSTSEC-2016-0002","url":"https://osv.dev/vulnerability/RUSTSEC-2016-0002"}],"summary":"HTTPS MitM vulnerability due to lack of hostname verification"}