{"action":"Upgrade moodle/moodle to 4.1.18 or later.","affected":[{"fixed":"4.1.18","introduced":"0"},{"fixed":"4.3.12","introduced":"4.3.0-beta"},{"fixed":"4.4.8","introduced":"4.4.0-beta"},{"fixed":"4.5.4","introduced":"4.5.0-beta"}],"component":"moodle/moodle","cve_ids":["CVE-2025-3642"],"ecosystem":"Packagist","epss":0.01058,"exploited":false,"fixed_versions":["4.1.18","4.3.12","4.4.8","4.5.4"],"ghsa_id":"GHSA-m367-445c-2xqr","id":"tcs_01M5KF52MVHY2Y5PSTJR0CHA6D","modified_at":"2026-01-26T17:41:08.968043Z","published_at":"2025-04-25T15:31:23Z","references":["https://osv.dev/vulnerability/GHSA-m367-445c-2xqr","https://nvd.nist.gov/vuln/detail/CVE-2025-3642","https://github.com/moodle/moodle/commit/630fbf6230ee18d63ce69bea34173fb151b599da","https://access.redhat.com/security/cve/CVE-2025-3642","https://bugzilla.redhat.com/show_bug.cgi?id=2359738","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=467603"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-m367-445c-2xqr","url":"https://osv.dev/vulnerability/GHSA-m367-445c-2xqr"}],"summary":"Moodle has an authenticated remote code execution risk in the Moodle LMS EQUELLA repository"}