{"action":"Upgrade tensorflow to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow","cve_ids":["CVE-2021-29519"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-772j-h9xw-ffp5","id":"tcs_01M5KF55JPZC12KYPNJGGJ2MAD","modified_at":"2026-07-08T06:00:29.098736042Z","published_at":"2021-05-21T14:21:08Z","references":["https://osv.dev/vulnerability/GHSA-772j-h9xw-ffp5","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-772j-h9xw-ffp5","https://nvd.nist.gov/vuln/detail/CVE-2021-29519","https://github.com/tensorflow/tensorflow/commit/b1cc5e5a50e7cee09f2c6eb48eb40ee9c4125025","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-447.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-645.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-156.yaml"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-772j-h9xw-ffp5","url":"https://osv.dev/vulnerability/GHSA-772j-h9xw-ffp5"}],"summary":"CHECK-fail in SparseCross due to type confusion"}