{"action":"Upgrade ansible-runner to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"2.0.0"}],"component":"ansible-runner","cve_ids":["CVE-2021-3702"],"ecosystem":"PyPI","epss":0.00204,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-772j-xvf9-qpf5","id":"tcs_01M5KF564J89FQBAW66KMDNKWG","modified_at":"2024-11-26T16:24:33.368862Z","published_at":"2022-08-24T00:00:29Z","references":["https://osv.dev/vulnerability/GHSA-772j-xvf9-qpf5","https://nvd.nist.gov/vuln/detail/CVE-2021-3702","https://github.com/ansible/ansible-runner/pull/742","https://github.com/ansible/ansible-runner/pull/742/commits","https://github.com/ansible/ansible-runner/commit/93e95a3df9021a38010386d07df121392d249253","https://access.redhat.com/security/cve/CVE-2021-3702","https://bugzilla.redhat.com/show_bug.cgi?id=1977965","https://github.com/pypa/advisory-database/tree/main/vulns/ansible-runner/PYSEC-2022-43068.yaml"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-772j-xvf9-qpf5","url":"https://osv.dev/vulnerability/GHSA-772j-xvf9-qpf5"}],"summary":"ansible-runner vulnerable to Race Condition"}