{"action":"Upgrade goodoneuz/pay-uz to 3.0.0 or later.","affected":[{"fixed":"3.0.0","introduced":"0"}],"component":"goodoneuz/pay-uz","cve_ids":["CVE-2026-31843"],"ecosystem":"Packagist","epss":0.01383,"exploited":false,"fixed_versions":["3.0.0"],"ghsa_id":"GHSA-m5wg-cjgh-223j","id":"tcs_01M5KF56T0J9PDF1MPR9P0DNYM","modified_at":"2026-07-27T15:15:32.070493011Z","published_at":"2026-04-16T15:31:32Z","references":["https://osv.dev/vulnerability/GHSA-m5wg-cjgh-223j","https://nvd.nist.gov/vuln/detail/CVE-2026-31843","https://github.com/shaxzodbek-uzb/pay-uz/pull/73","https://github.com/goodoneuz/pay-uz/blob/master/src/Http/Controllers/ApiController.php","https://github.com/goodoneuz/pay-uz/blob/master/src/routes/web.php","https://github.com/shaxzodbek-uzb/pay-uz","https://github.com/shaxzodbek-uzb/pay-uz/releases/tag/3.0.0","https://packagist.org/packages/goodoneuz/pay-uz"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-m5wg-cjgh-223j","url":"https://osv.dev/vulnerability/GHSA-m5wg-cjgh-223j"}],"summary":"goodoneuz/pay-uz: the /payment/api/editable/update endpoint overwrites existing PHP payment hook files"}