{"action":"Upgrade buddypress/buddypress to 7.2.1 or later.","affected":[{"fixed":"7.2.1","introduced":"5.0.0"}],"component":"buddypress/buddypress","cve_ids":["CVE-2021-21389"],"ecosystem":"Packagist","epss":0.14811,"exploited":false,"fixed_versions":["7.2.1"],"ghsa_id":"GHSA-m6j4-8r7p-wpp3","id":"tcs_01M5KF589ZE3E7DGRZC1K7DHG8","modified_at":"2026-07-08T06:28:55.844552312Z","published_at":"2021-10-06T17:46:55Z","references":["https://osv.dev/vulnerability/GHSA-m6j4-8r7p-wpp3","https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3","https://nvd.nist.gov/vuln/detail/CVE-2021-21389","https://buddypress.org/2021/03/buddypress-7-2-1-security-release","https://codex.buddypress.org/releases/version-7-2-1","https://github.com/buddypress/BuddyPress"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-m6j4-8r7p-wpp3","url":"https://osv.dev/vulnerability/GHSA-m6j4-8r7p-wpp3"}],"summary":"BuddyPress privilege escalation via REST API"}