{"action":"Upgrade ansible to 2.7.17 or later.","affected":[{"fixed":"2.7.17","introduced":"2.7.0a1"},{"fixed":"2.8.11","introduced":"2.8.0a1"},{"fixed":"2.9.7","introduced":"2.9.0a1"}],"component":"ansible","cve_ids":["CVE-2020-10685"],"ecosystem":"PyPI","epss":0.00364,"exploited":false,"fixed_versions":["2.7.17","2.8.11","2.9.7"],"ghsa_id":"GHSA-77g3-3j5w-64w4","id":"tcs_01M5KF58VHP0476XHE097CC3EN","modified_at":"2024-09-06T20:21:58.340579Z","published_at":"2021-04-07T20:36:46Z","references":["https://osv.dev/vulnerability/GHSA-77g3-3j5w-64w4","https://nvd.nist.gov/vuln/detail/CVE-2020-10685","https://github.com/ansible/ansible/pull/68433","https://github.com/ansible/ansible/commit/4e1fe80e681fa466626e9dea53efe6b0253ea1b2","https://github.com/ansible/ansible/commit/51d2514753544a9d58cd7524e27e696b2c944fb5","https://github.com/ansible/ansible/commit/e1273b6faf036ed84e4f4edee85b888a4e256aee","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10685","https://github.com/advisories/GHSA-77g3-3j5w-64w4","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-1.yaml","https://security.gentoo.org/glsa/202006-11","https://www.debian.org/security/2021/dsa-4950"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-77g3-3j5w-64w4","url":"https://osv.dev/vulnerability/GHSA-77g3-3j5w-64w4"}],"summary":"Exposure of Resource to Wrong Sphere and Insecure Temporary File in Ansible"}