{"action":"Upgrade apache-airflow to 1.10.1 or later.","affected":[{"fixed":"1.10.1","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2018-20245"],"ecosystem":"PyPI","epss":0.01016,"exploited":false,"fixed_versions":["1.10.1"],"ghsa_id":"GHSA-77rc-x84q-pv4f","id":"tcs_01M5KF5AFC6KX4QTSQ9VVWPQ4R","modified_at":"2024-09-04T21:01:29.984859Z","published_at":"2019-01-25T16:19:19Z","references":["https://osv.dev/vulnerability/GHSA-77rc-x84q-pv4f","https://nvd.nist.gov/vuln/detail/CVE-2018-20245","https://github.com/apache/airflow/commit/28abf87bd173cc4cedc57f553118470e5745a968","https://github.com/apache/airflow/commit/66d0d05ea0802aec407e0ef5435a962080db0926","https://github.com/apache/airflow/commit/d8d0e8c59203f793f81d47d5adb1362df0b5d8d1","https://github.com/advisories/GHSA-77rc-x84q-pv4f","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-143.yaml","https://lists.apache.org/thread.html/b549c7573b342a6e457e5a3225c33054244343927bbfb2a4cdc4cf73@%3Cdev.airflow.apache.org%3E"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-77rc-x84q-pv4f","url":"https://osv.dev/vulnerability/GHSA-77rc-x84q-pv4f"}],"summary":"Improper Certificate Validation in Apache Airflow"}