{"action":"Upgrade github.com/lf-edge/ekuiper/v2 to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"github.com/lf-edge/ekuiper/v2","cve_ids":["CVE-2024-52290"],"ecosystem":"Go","epss":0.00304,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-9cwv-pxcr-hfjc","id":"tcs_01M5KF5DVP7DXA9HF5W3DE35B7","modified_at":"2026-09-10T03:50:57.450811419Z","published_at":"2025-05-14T21:41:26Z","references":["https://osv.dev/vulnerability/GHSA-9cwv-pxcr-hfjc","https://github.com/lf-edge/ekuiper/security/advisories/GHSA-9cwv-pxcr-hfjc","https://nvd.nist.gov/vuln/detail/CVE-2024-52290","https://github.com/lf-edge/ekuiper/commit/943c02e10f0f8349e609474810eab5fa460d1a51","https://github.com/lf-edge/ekuiper"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-9cwv-pxcr-hfjc#Go/github.com/lf-edge/ekuiper/v2","url":"https://osv.dev/vulnerability/GHSA-9cwv-pxcr-hfjc"}],"summary":"LF Edge eKuiper Vulnerable to Stored XSS in Configuration Key Functionality"}