{"action":"Upgrade nicegui to 3.8.0 or later.","affected":[{"fixed":"3.8.0","introduced":"0"}],"component":"nicegui","cve_ids":["CVE-2026-27156"],"ecosystem":"PyPI","epss":0.00196,"exploited":false,"fixed_versions":["3.8.0"],"ghsa_id":"GHSA-78qv-3mpx-9cqq","id":"tcs_01M5KF5E6DS8YC1B242KYAB5QK","modified_at":"2026-07-13T07:26:13.919508653Z","published_at":"2026-02-24T19:56:18Z","references":["https://osv.dev/vulnerability/GHSA-78qv-3mpx-9cqq","https://github.com/zauberzeug/nicegui/security/advisories/GHSA-78qv-3mpx-9cqq","https://nvd.nist.gov/vuln/detail/CVE-2026-27156","https://github.com/zauberzeug/nicegui/commit/1861f59cc374ca0dc9d970b157ef3774720f8dbf","https://github.com/zauberzeug/nicegui"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-78qv-3mpx-9cqq","url":"https://osv.dev/vulnerability/GHSA-78qv-3mpx-9cqq"}],"summary":"NiceGUI vulnerable to XSS via Code Injection during client-side element function execution"}