{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29579"],"ecosystem":"PyPI","epss":0.00214,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-79fv-9865-4qcv","id":"tcs_01M5KF5JVBCPNKJ1TZAW0F30R8","modified_at":"2026-07-08T06:28:23.021669632Z","published_at":"2021-05-21T14:26:23Z","references":["https://osv.dev/vulnerability/GHSA-79fv-9865-4qcv","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-79fv-9865-4qcv","https://nvd.nist.gov/vuln/detail/CVE-2021-29579","https://github.com/tensorflow/tensorflow/commit/a74768f8e4efbda4def9f16ee7e13cf3922ac5f7","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-507.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-705.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-216.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-79fv-9865-4qcv#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-79fv-9865-4qcv"}],"summary":"Heap buffer overflow in `MaxPoolGrad`"}