{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29576"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-7cqx-92hp-x6wh","id":"tcs_01M5KF5R4MPRB1AKSH0TV516HY","modified_at":"2026-07-08T06:28:03.970193291Z","published_at":"2021-05-21T14:26:16Z","references":["https://osv.dev/vulnerability/GHSA-7cqx-92hp-x6wh","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7cqx-92hp-x6wh","https://nvd.nist.gov/vuln/detail/CVE-2021-29576","https://github.com/tensorflow/tensorflow/commit/63c6a29d0f2d692b247f7bf81f8732d6442fad09","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-504.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-702.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-213.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-7cqx-92hp-x6wh#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-7cqx-92hp-x6wh"}],"summary":"Heap buffer overflow in `MaxPool3DGradGrad`"}